Fandom

NWN2Wiki

System requirements

3,791pages on
this wiki
Add New Page
Talk18 Share

The system requirements to run the NWN2 game are as follows. Please note that these specifications could change prior to launch.

Recommended system requirementsEdit

  • Operating System: Windows XP
  • Processor: Intel Pentium 4 3.0 GHz or AMD Athlon 64 or equivalent (or higher)
  • Memory: 1GB RAM
  • Hard Disk Space: 5.5GB Free
  • CD-ROM or DVD-ROM drive: 4x(DVD) 8x(CD)
  • Video: 256MB Pixel Shader Model 2.0 (ATI X1600 or nVidia 6800 GT/GS or better) - should be compatible with DirectX version 9.0c or higher
  • Sound: Windows XP-compatible sound card
  • Multiplayer: Local area network with TCP/IP protocol or Broadband Internet connection
  • DirectX: DirectX version 9.0c or higher (included)
  • Microsoft .NET 2.0 Framework for toolset (included)
  • Keyboard, Mouse

Minimum system requirementsEdit

  • Operating System: Windows XP
  • Processor: Intel Pentium 4 2.4 GHz or AMD Athlon XP 2000 or equivalent
  • Memory: 512MB RAM
  • Hard Disk Space: 5.5GB Free
  • CD-ROM or DVD-ROM drive: 4x(DVD) 8x(CD)
  • Video: 128MB Pixel Shader 2.0 (ATI 9700 Pro or nVidia 6800 or better) - should be compatible with DirectX version 9.0c or higher
  • Sound: Windows XP-compatible sound card
  • Multiplayer: Local area network with TCP/IP protocol or Broadband Internet connection
  • DirectX: DirectX version 9.0c or higher (included)
  • Microsoft .NET 2.0 Framework for toolset (included)
  • Keyboard, Mouse

DVD Drive WarningEdit

Only some DVD-RW Drives are able to read the DVD-ROM version due to Securom.

Non-Working drives:

  • PLEXTOR DVDR PX-760A (Firmware 1.01-1.04)

Known Good drives:

  • TSSTcorp CD/DVDW SH-S182D
  • Matsushita UJ-857 series

Supported video cardsEdit

  • ATI Radeon X1900 series
  • ATI Radeon X1800 series
  • ATI Radeon X1600 series
  • ATI Radeon X850 series
  • ATI Radeon X800 series
  • ATI Radeon X700 series
  • ATI Radeon X600 series
  • ATI Radeon 9800 series
  • ATI Radeon 9600 series
  • ATI Radeon 9500 Pro
  • NVIDIA GeForce 7950 series
  • NVIDIA GeForce 7900 series
  • NVIDIA GeForce 7800 series
  • NVIDIA GeForce 7600 series
  • NVIDIA GeForce 6800 series
  • NVIDIA GeForce 6600 series

( DirectX 9.0c is not compatible with GeForce series 5 )

NWN2 web site FAQsEdit

1. Will Neverwinter Nights 2 support NVIDIA’s SLI feature?

Yes, if you have two video cards that make use of SLI, Neverwinter Nights 2 will support them.

2. Does Neverwinter Nights 2 support AMD 64-bit processors?

Yes, we’re planning to fully support AMD 64-bit processors running Windows XP; however, the game does not support Windows XP x64 edition.

3. Will Neverwinter Nights 2 make use of dual core CPU’s?

The Neverwinter Nights 2 Toolset is a multithreaded application; as a result, it will utilize the benefits of dual-core processors from both AMD and Intel.

4. Does Neverwinter Nights 2 still use the Aurora graphics engine?

Neverwinter Nights 2’s graphics engine has been replaced by the next-generation Electron engine, which supports advanced graphical features like fully dynamic lighting, normal mapping, specular mapping, shadow maps, and more.

5. Will Neverwinter Nights 2 make use of advanced features of newer video cards?

Yes -- The game fully supports Shader Model 2.0 and 3.0 cards (such as the NVIDIA GeForce 6 and 7 series and the ATI Radeon X1800) to achieve stunning visual effects at a much higher framerate than possible on older video cards.
The game requires at least a DirectX 9.0c compatible video card that supports at least Shader Model 2.0.

Pre-release notesEdit

  • Obsidian has stated that the "game runs great and looks great on all of our supported [video] cards, regardless of vendor. I'd look more to the performance features of the GPU than to the vendor when making my decision to upgrade." [1] Also, the "visual fidelity on either of the major vendors is pretty much equal. I attribute that to the fact that we've written the rendering engine to the DX9 spec. and not tried to get out there crazy with vendor specific features." [2]
  • The 3 Aug 2006 beta test announcement repeated the above system requirements. [3]

External linksEdit

Ad blocker interference detected!


Wikia is a free-to-use site that makes money from advertising. We have a modified experience for viewers using ad blockers

Wikia is not accessible if you’ve made further modifications. Remove the custom ad blocker rule(s) and the page will load as expected.